Congstar: Good speed without operator logo

Even after my now successful Change from o² to congstarI am affected by the problem of the missing provider display. In forums like telefon-treff.de there has been talk for some time about the fact that Congstar SIM cards do not issue an operator ID - at least not when using an iPhone. This does not affect the functionality, only the corrected SIM card should be sent. My SIM, which arrived last week (week 27), still seems to have the problem.

But a first speed test at my home has shown useful results: 75ms ping, 4.8 MBit/s download and 1.33 MBit/s upload are enough to call mobile websites without major delays. If congstar now sends reliable SIM cards with provider display, I will also request a new SIM from the support - which will hopefully output "congstar", even if the missing provider doesn't have a functional disadvantage, it's nicer if everything works as it should. And: in my case the reception is better than with Vodafone (fyve).

Congstar speed test in the southern part of Fürth

Update: Even if it was not expected, but it would have been possible; But even with iOS 6 the appropriate information is missing to display the Congstar operator logo. So there is nothing new on the operator logo front at Congstar yet.

Update 2: I did another speed test to verify the first results. Also in Munich (near the Einstein shopping center) Congstar (or T-Mobile) delivers good speed, even a bit more than at an old location in Nuremberg. Here is the Congstar speed test result:

Congstar speed test in Munich

Update 3: Nano-SIM with operator logo
The Nano-SIM, which I used for my iPhone 5 from Congstar now also provides an operator logo. I haven't tried if this can be replaced by something else (instructions are available on the net) - but that's next on the plan, if there is a nice T-Mobile logo instead of the Congstar lettering.

Update 4: new speed test
I did a speed test again - under good conditions you simply notice that Congstar throttles down at 7.2 Mbit/s, the T-Mobile network delivers quite good data rates.

Congstar speed test in March
Congstar speed test in March

17 thoughts on “Congstar: Guter Speed ohne Betreiberlogo”

  1. Look out! If you order a replacement card, your existing card will be deactivated without prior notice. I've done that, I can only advise against it! The new card I received then had - who is surprised? - also no logo! So 30 hours without a working SIM card, chapeau Congstar!

    1. Well, they seem to have that under control now - nothing happened until I called the hotline to order the replacement card. Also the PIN can only be found out at the hotline (that's more annoying)

  2. tibeh :

    Look out! If you order a replacement card, your existing card will be deactivated without prior notice. I've done that, I can only advise against it! The new card I received then had - who is surprised? - also no logo! So 30 hours without a working SIM card, chapeau Congstar!

    Yes, I have read that already - but I don't mind that the provider display is missing, so I will not apply for a card exchange.

  3. But you write: "If congstar now sends SIM cards with provider display reliably, I will also request a new SIM via support - which will hopefully output "congstar", even if the missing provider has no functional disadvantage, it's nicer if everything works as it should.

  4. tibeh :

    But you write: "If congstar now sends SIM cards with provider display reliably, I will also request a new SIM via support - which will hopefully output "congstar", even if the missing provider has no functional disadvantage, it's nicer if everything works as it should.

    As I said, it is "nicer", but no one has to 😉

  5. Just so to the info: My card, which arrived on 31.10.2012 (newly concluded contract) does not show the logo either! (iPhone 3GS, iOS 6.0)

  6. So I got my Sim on 17.11.2012 delivered, this shows in the Iphone 4s also no provider!

    But I have no problem with that 🙂

  7. Matthias :

    Whether LTE or not, the whole thing is probably capped at 7.2Mbit ...
    I've achieved 7 Mbit even without LTE.

    Well, the ping seems to be much better with LTE - and 7.2 Mbit/s is enough for me to surf on the go.

  8. 21.06.2013 Still no provider indication in the display. Also under Settings/Network provider only the 3 competitors (Vodafone.de, E-Plus and O2-de) are listed, so I have checked the invisible line . Is all this really state-of-the-art?

Leave a Comment

Your email address will not be published. Required fields are marked *

en_USEnglish
Scroll to Top